メインコンテンツへ移動

利用規約

端末内で処理

クライアントサイド開発者ユーティリティのための、シンプルで正直な利用規約

1. 規約への同意

toolsbyus.com(「本サービス」)にアクセスし、または利用することで、本利用規約に拘束されることに同意したものとみなされます。規約の一部に同意できない場合は、いつでもサイトの利用をやめることができます。

2. 知的財産とペイロードの所有権

あなたのデータはあなたのものです: ToolsByUsで処理、検証、比較、整形したコード、JSONペイロード、トークン、スキーマ、テキスト、設定ファイルは、すべてあなたの専有的な知的財産であり続けます。

ToolsByUsは完全にクライアントサイドで、あなたのブラウザの中で実行されるため、ペイロードが当方のサーバーに送信されたり保存されたりすることはありません。当方は、ツールで処理されたデータに対して、所有権、ライセンス、閲覧・利用・複製の権利を一切主張しません。

3. 許容される利用

ToolsByUsは合法的な目的に限って使用することに同意するものとします。次の行為は行わないものとします:

  • 当方のエッジCDNホスティングインフラに対する自動化されたサービス拒否(DoS)攻撃への関与。
  • 当方の広告インフラのスクレイピング、リバースエンジニアリング、回避の試み。
  • 本サービスを、悪意のあるバイナリや攻撃用ペイロードの配布に使うこと。

4. 「現状有姿」の保証の否認

ToolsByUsは「現状有姿」かつ「利用可能な状態のまま」提供され、商品性、特定目的への適合性、非侵害を含む(ただしこれらに限定されない)、明示または黙示のいかなる保証も伴いません。

当方のdiffアルゴリズム、パーサー、スキーマジェネレーターはRFC 8259、RFC 6902、RFC 7386、RFC 9562、JSON Schemaの仕様に厳密に準拠していますが、サービスが完全にエラーなく動作することや、結果があなたの特定の業務要件を満たすことを保証するものではありません。重要な本番システムに適用する前に、すべての出力を確認・検証する責任はあなたにあります。

5. 責任の制限

適用法で許される最大の範囲において、toolsbyus.comの作者または運営者は、本サービスの利用または利用不能に起因し、あるいは関連する一切の直接損害、間接損害、偶発損害、特別損害、結果的損害、懲罰的損害について責任を負いません。

6. 変更

本規約は随時更新されることがあります。変更はすべてこのURLに直接掲載され、重要な変更は発効前に更新履歴で告知されます。この規約をプレーンテキストで公開しているのは意図的です。仲裁すべきアカウントも、ユーザーごとに交渉すべき事項もありません。この文書はサイトの動作を記述するか、記述するまで書き直されるかのどちらかです。